Compatible Devices

EVO Gimbals Remote APP for iOS v2.0.5
iPhones Require iOS 9.0 or later. Compatible with:

EVO Gimbals Remote APP for Android v2
Requires Android 5.0 or higher. Compatible with:

Action Cameras:


1EVO Adapter Plate NOT Included

The device support list will be updated continuously.

Back